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Preface

Thank you for purchasing Autonics products.
Be sure to read and follow the Safety Precautions thoroughly before use.
This manual contains information about the product and how to use it properly, so keep it in a place
where users can easily find it.

Preface 　 5
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Manual Guide

• Use the product after fully reading the contents of the manual.

• The manual explains the product functions in detail and does not guarantee the contents other than
the manual.

• Any or all of the manual may not be edited or copied without permission.

• The manual is not provided with the product.

• Download and use from our website (www.autonics.com).

• The contents of the manual are subject to change without prior notice according to the improvement
of the product’s performance, and upgrade notices are provided through our website.

• We put a lot of effort to make the contents of the manual a little easier and more accurate.
Nevertheless, if you have any corrections or questions, please feel free to comment through our
website.

Manual Guide 　 7
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Common Symbols in the Manual

Failure to follow instructions may result in serious injury or death.

Failure to follow instructions may result in injury or product damage.

Supplementary explanation of the function

Example of that function

Important information about the feature

Common Symbols in the Manual 　 9
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Safety Considerations

Observe all 'Safety Considerations' for safe and proper operation to avoid hazards.

　Warning
1. Fail-safe device must be installed when using the unit with machinery that may cause serious injury

or substantial economic loss. (e.g., nuclear power control, medical equipment, ships, vehicles,
railways, aircraft, combustion apparatus, safety equipment, crime/disaster prevention devices, etc.)
Failure to follow this instruction may result in personal injury, fire or economic loss.

2. Do not use the unit in the place where flammable/explosive/corrosive gas, high humidity, direct
sunlight, radiant heat, vibration, impact, or salinity may be present.
Failure to follow this instruction may result in explosion or fire.

3. Do not disassemble or modify the unit.
Failure to follow this instruction may result in fire.

4. Do not connect, repair, or inspect the unit while connected to a power source.
Failure to follow this instruction may result in fire.

5. Check ‘Connections’ before wiring.
Failure to follow this instruction may result in fire.

　Caution
1. Use the unit within the rated specifications.

Failure to follow this instruction may result in fire or shortening the life cycle of the product.

2. Use dry cloth to clean the unit, and do not use water or organic solvent.
Failure to follow this instruction may result in fire or electric shock.

3. When connecting the power input and output, use AWG 22-16 cable and check the connecting
method of crimp terminal.
Failure to follow this instruction may result in fire or malfunction due to contact failure.

4. Keep metal chip, dust, and wire residue from flowing into the unit.
Failure to follow this instruction may result in fire or product damage.

5. Do not connect or disconnect connector (terminal) wire or power, when the product is operating.
Failure to follow this instruction may result in fire or malfunction of the product.

Safety Considerations 　 11



　Cautions during Use
1. Follow instructions in ‘Cautions during Use’. Otherwise, It may cause unexpected accidents.

2. BUS power and I/O power should be insulated by the individually insulated power device.

3. Power supply should be insulated and limited voltage/current or Class 2, SELV power supply device.

4. Use the rated standard cables and connectors. Do not apply excessive power when connecting or
disconnecting the connectors of the product.

5. Keep away from high voltage lines or power lines to prevent inductive noise.
In case installing power line and input signal line closely, use line filter or varistor at power line and
shielded wire at input signal line. For stable operation, use shield wire and ferrite core, when wiring
communication wire, power wire, or signal wire.

6. Do not use near the equipment which generates strong magnetic force or high frequency noise.

7. Do not touch the module communication connector part of the base.

8. Do not connect, or remove the base while connected to a power source.

9. For removing the terminal, body or base, do not operate units for a long time without it.

10. This unit may be used in the following environments.
① Indoors (in the environment condition rated in ‘Specifications’)
② Altitude max. 2,000 m
③ Pollution degree 2
④ Installation category II

The specifications and dimensions of this manual are subject to change without any notice for product
improvement. Be sure to read and follow the considerations written in the instruction manual, other
manuals, and technical information on our Autonics website.
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1. Reference Manuals

Be sure to read the reference manuals below to use the product correctly and follow
the precautions written in these manuals.
You can download the reference manuals on our Autonics website.

Installation manual It contains information for you to setup and install the ARIO Unit.

1. Key features of ARIO Series

2. Environmental conditions and handling method for
installation

3. Installation precautions

4. Instructions about maintenance, etc.

1. Reference Manuals 　 13



Coupler manual It contains information for you to configure and use the coupler
in the field network.

1. Communication protocol overview

2. Hardware information: specifications, indicators, connection
diagram, and dimensions, etc.

3. Software information: process images, and mapping
information, etc.

Module manual It contains information on the modules provided by Autonics.

1. Hardware information: specifications, indicators, connection
diagram, and dimensions, etc.

DAQMaster user manual It contains information and usage guides on ARIO-related
functions supported by DAQMaster, the comprehensive device
management program.

1. Change properties of the coupler and modules

2. Module configuration via virtual mode

3. Check the address map of the Unit

4. Check the diagnostic information of the coupler

5. Update the firmware version of the coupler, etc.
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2. Overview of ARIO-C-DN

2.1. DeviceNet Protocol
DeviceNet is a multi-drop network that is easy to connect with multiple devices such as PLCs, sensors,
and actuators. With DeviceNet, you can reduce costs for wiring and constructing a system in a multi-
vendor environment. This protocol is widely used in many industrial sites such as semiconductor
equipment and automobile manufacturing facilities.

DeviceNet utilizes the CAN bus on the data link and Common Industrial Protocol (CIP) on the network
layer in the OSI layer, similar to the EtherNet/IP protocol. The CIP protocol allows messages to be
transmitted to CIP-based networks such as EtherNet/IP so that you can manage control-related data
through the services and profiles for real-time control applications from a variety of production
systems.

The ARIO-C-DN supports the DeviceNet protocol. This coupler composes the physical structure of
connected modules and devices and creates input and output process images linked with the data of
DeviceNet. The process images make it possible to experience a flexible installation environment,
such as the mixed arrangement of analog and digital modules.

2.1. DeviceNet Protocol 　 15



2.2. Unit Descriptions

1. DeviceNet Communication Connector It is a connector to connect with DeviceNet
Master such as PLC.
For detailed information on the communication
cable, refer to the  2.3, “DeviceNet
Communication Connector”.

2. DATARATE Rotary Switch It is a setting switch to set the baud rate in the
DeviceNet communication network.
For detailed information on selecting the baud
rate, refer to the  2.4, “Set the Baud Rate”.

3. Decimal Rotary Switches It is a setting switch to designate the node
address (MAC-ID) of the coupler in the DeviceNet
communication network. You can also set the
node address in the DAQMaster.
For detailed information on addressing method,
refer to the  2.5, “Assign the Node Address (MAC-
ID)”.
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4. CONFIG Port It is a port to connect to the PC where
DAQMaster is installed.

1. Port type: USB Type-B Micro

5. Indicators It displays the status of the coupler and
communication connection as shown below.
For detailed information on the indicators,
refer to the  3, Indicators.

1. Power and operating status of the coupler

2. DeviceNet communication status

6. Power Supply Terminal It is a terminal block that supplies power to the
coupler and peripherals.
For detailed information on the device supply,
refer to the  2.6, “Connections of the Power
Terminal”.

7. Power Supply Contacts It is a contact that feeds the power input from
the power supply terminal.

1. Top input contacts: feed the power supply for
the coupler, module, and ABUS to be
operated.

2. Bottom input contacts: feed the power supply
for input and output signals of the connected
module.

2.2. Unit Descriptions 　 17



2.3. DeviceNet Communication Connector

• Be sure to use the connector and cable approved by the Open DeviceNet Vendors
Association (ODVA).

The 5-pin PCB connector is used for the DeviceNet communication connection.
For more information on the pin assignment, refer to the table below.

Pin no. Marking on the connector Color Description

1 V+ Red +24 VDC DeviceNet power input

2 H: CAN_H White CAN High signal

3 SH: Shield - Shield

4 L: CAN_L Blue CAN Low signal

5 V- Black Signal ground (-24 VDC, 0 VDC)
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2.4. Set the Baud Rate

• Be sure to use the connector and cable approved by the Open DeviceNet Vendors
Association (ODVA).

• Be sure not to exceed the maximum cable length of each baud rate.

Refer to the table below for you to set the baud rate of DeviceNet via the DATARATE rotary switch.
The selected baud rate should be the same as the type of DeviceNet Master.

Rotary switch Baud rate Trunk cable length Drop cable length

0 125 kbps • Thick cable: ≤ 500 m
• Thin cable: ≤ 100 m

• Thick/Thin cable: ≤ 6 m
• Cumulative drop line: ≤ 156 m

1 250 kbps • Thick cable: ≤ 250 m
• Thin cable: ≤ 100 m

• Thick/Thin cable: ≤ 6 m
• Cumulative drop line: ≤ 78 m

2 500 kbps • Thick cable: ≤ 100 m
• Thin cable: ≤ 100 m

• Thick/Thin cable: ≤ 6 m
• Cumulative drop line: ≤ 39 m

2.4. Set the Baud Rate 　 19



2.5. Assign the Node Address (MAC-ID)

• It is recommended to designate the node address of the coupler the same as the
value of the rotary switches.

• The node address cannot be applied while the coupler is operating.

• Be sure to start the coupler again to apply the changed node address.

You can assign the coupler’s node address via two decimal rotary switches.

Assign mode Rotary switches (x10, x1) Node address

Default node address 00 3

The node address of the coupler 01 to 63 1 to 63

2.5.1. Assign the Node Address in the DAQMaster
1. Set the positions of the coupler’s rotary switches to 0x00.

2. To designate the node address in the DAQMaster, go to the Comm Mode » Property tab of the
coupler » Node Address and press the Enter key.

3. Reset the ARIO unit in the DAQMaster.

4. The node address assigned by the DAQMaster is applied.
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2.6. Connections of the Power Terminal

Terminal no. Name Description

1, 7 System Power (24 VDC) Power supply for the coupler, module and
ABUS to be operated.
• The terminals feed the power supply to the
top input contacts.
• The POWER indicator lights up.

2, 8 System Power (0 VDC)

3, 9 Not Connected (NC) -

4, 10 Field Power (Positive: 24 VDC) Power supply for the input and output (I/O)
signals of the module.
• The terminals feed the power supply to the
bottom input contacts.
• The IO POWER indicator lights up.

5, 11 Field Power (Negative: 0 VDC)

6, 12 Frame Ground / Shield Frame ground

2.6. Connections of the Power Terminal 　 21
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3. Indicators

The indicators of the ARIO-C-DN coupler consist of elements indicating the operating status for the
coupler and connection status for the field network (DeviceNet) as shown in the figure below.
For detailed information on each indicator, refer to the following tables below.

3. Indicators 　 23



3.1. LEDs for the Coupler Status
1. The power supply status of the coupler

Indicator LED color Status Description

POWER Green ON Supply voltage: Normal

OFF Supply voltage: None

2. The status of the standby mode

Indicator LED color Status Description

SYSTEM Green ON Normal operation

Flashing Standby for connecting the master after
initialization of the coupler

OFF Stop

Red ON • Coupler initialization failure (non-recoverable)
• An unrecoverable error occurred.
• The type of field network and firmware version
mismatch (non-recoverable)

Flashing • Field network initialization failure
(non-recoverable)
• Changing the settings of rotary switches
(applicable models)

OFF Normal operation

3. The status of the module communication (ABUS)

Indicator LED color Status Description

DIAG Green ON Normal operation: Multi/Single-packet works

Flashing Hot-swap (normal state)

OFF • The operation of the coupler stopped
• An error occurred

Red ON ABUS communication error

Flashing The models of the replaced module and the
previous one mismatch (normal operation)

Flashing (2 times) No module connection (non-recoverable)

Flashing (3 times) Abnormal module operation (non-recoverable)

Flashing (4 times) The number of modules and data size exceeded

OFF Normal operation
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4. The status of power supply for the module

Indicator LED color Status Description

IO POWER Green ON I/O supply voltage of the module: Normal

OFF I/O supply voltage of the module: None
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3.2. LEDs for the Field Network Status
1. The module/network status

Indicator LED color Status Description

MNS Green ON The device is operating correctly and the connection is
established.

Flashing • The device is in online mode but has no connection.
• Configuration information could not be read
• Configuration error (invalid or incomplete configuration)

OFF The device is in INIT state (DeviceNet communication
initialization, communication unavailable)

Red ON Critical fault or network connection failure
• Duplicate MAC-ID
• Severe error occurred in CAN network (CAN Bus off)

Flashing Minor or recoverable fault
• Connection timeout
• No data exchange with a slave
• No network supply voltage

OFF • Device Supply voltage: None
• Device power is applied but there is no network supply
voltage.
• MAC address validation (Dup_MAC_ID test) not yet
completed

Green/Red OFF • Device supply voltage: None
• Network supply voltage: None
• MAC address validation (Dup_MAC_ID test) not yet
completed

Flashing Self-test: The device is performing its power up testing.
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Refer to the timing chart below for the flashing operation of indicators.
The operation is repeated as flashing every 200 microseconds and standby
for 1 second.
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4. Process Images

4.1. Memory Map
The ARIO unit composes the memory map in its memory space to assign and manage the data
collected by the coupler and modules. The master in the field network controls the input and output
devices via this memory map generated by the ARIO unit.

The memory map is created based on the arrangement and data structure of the ARIO unit as shown in
the figure below. The memory map of modules consists of each module and contains its data.
The memory map of the coupler allocates the data considering the type (input or output) and
sequence of connected modules (e.g., the slot number of each module), and data size to the read and
write areas, making it easy to calculate the location of the master’s register. In this way, the memory
map comprised by the ARIO unit creates the input and output process images for data exchange.

• READ area
It is the area that transmits the data collected by the unit to the master in the field network.
It contains the input and diagnostic data.

• WRITE area
It is the area that transmits the output commands from the master of the field network.
It contains the output data.
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4.2. Data Processing in the Modules
The data of the module is processed depending on the input and output signals.

• Digital modules
The bit-oriented digital module indicates the value of the corresponding bit position as 1.
The size of each channel is 1 bit and is grouped into bytes.

• Analog modules
The byte-oriented analog module indicates the value of the input or output signal to the
corresponding bytes. The size of each channel is grouped into words.

Module Example of input/output format Data processing size

Digital input/output
: Bit-oriented

2 channels/module (2-CH/module) 1-byte

4 channels/module (4-CH/module) 1-byte

8 channels/module (8-CH/module) 1-byte

16 channels/module (16-CH/module) 2-byte (= 1-word)

Analog input/output
: Byte-oriented

8-bit/channel (8-bit/CH) 1-byte

12-bit/channel (12-bit/CH) 2-byte (= 1-word)

16-bit/CH (16-bit/CH) 2-byte (= 1-word)

24-bit/channel (24-bit/CH) 4-byte (= 2-word)
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4.2.1. Check the Data of the Modules
You can check the data of modules connected with the coupler as shown in the figure below.
To check the data, go to Comm Mode » Run » I/O Monitor in the DAQMaster.
The binary, decimal, and hexadecimal are supported as the display format in the DAQMaster.

1. The value of input signals on the point (or channels) 1 and 2 of the digital input module
• Binary 0000 0011 (0x03)

2. The value of a voltage of 10.000 V applied to channel 1 of the analog input module
• Big endian: 0x270D (≈ 10,000DEC)

The data arrangements (the order or sequence) of the analog signal can be
expressed as big-endian or little-endian in the DAQMaster.
To select the endianness, go to Comm Mode » Property tab of the coupler »
Endian. (factory setting: Big-endian)
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4.3. Example of the Process Image
You can check the input and output process images of the unit (coupler + modules) on the AddressMap

menu in the DAQMaster. Firstly, the input modules are mapped, and then the output modules are
mapped. The first position of the input process image contains diagnostic information of the coupler
with a size of 16 bits (1 word).

DAQMaster: An arrangement example of the ARIO unit

DAQMaster: The address map of the ARIO unit
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4.3.1. Input Process Image

Byte Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 0: Coupler Diagnostic Data High Byte 01)

1 Diagnostic data Low Byte 01)

2 2: DI04P - Ch.4 Ch.3 Ch.2 Ch.1

3 3: AI02V1 Ch.1 High Byte

4 Ch.1 Low Byte

5 Ch.2 High Byte

6 Ch.2 Low Byte

7 5: AI02V1 Ch.1 High Byte

8 Ch.1 Low Byte

9 Ch.2 High Byte

10 Ch.2 Low Byte

11 7: DI04P - Ch.4 Ch.3 Ch.2 Ch.1

12 9: DI04P - Ch.4 Ch.3 Ch.2 Ch.1

01) Refer to the  4.3.3, “Mapping of the Coupler Diagnostic Data”.

4.3.2. Output Process Image

Byte Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 1: AO02V1 Ch.1 High Byte

1 Ch.1 Low Byte

2 Ch.2 High Byte

3 Ch.2 Low Byte

4 4: DO04P - Ch.4 Ch.3 Ch.2 Ch.1

5 6: DO04P - Ch.4 Ch.3 Ch.2 Ch.1

6 8: DO08P Ch.8 Ch.7 Ch.6 Ch.5 Ch.4 Ch.3 Ch.2 Ch.1
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4.3.3. Mapping of the Coupler Diagnostic Data
To check the value of the coupler diagnosis in the DAQMaster,
go to Comm Mode » Property tab of the coupler » Coupler State.

Byte Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 High Reserved

1 Low CS MS WP AEM - ACS AT AC

AC (ABUS Configuration) The diagnostic information for the configuration of the
coupler and modules
0: Normal state
1: Module configuration error
• Cause 1: No connected modules
• Cause 2: The number of connected modules exceeded
• Cause 3: The data size of module exceeded
• Cause 4: Invalid arrangement of modules

AT (ABUS Timeout) The occurrence information of timeout
0: Multi-packet state (normal)
1: Single-packet state (timeout occurred)
• Cause 1: The module detached
• Cause 2: The module not recognized due to a noise
• Cause 3: Hot-swap state
• Cause 4: The module operation error

ACS (ABUS Communication State) ABUS communication status
0: Normal state
1: Communication error
• Cause 1: Replaced module mismatched
• Cause 2: Unknown communication error occurred

AEM (ABUS Empty Module) Checking the connected module
0: Normal state (one or more modules connected)
1: No module connected

WP (Warranty Period) Notice of product warranty period
(≤ 3 years, 157,680DEC)
0: Within the warranty period
1: End of warranty period
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MS (Module State) The status of connected modules
(running with DIAG indicator)
0: Normal state
1: Error

CS (Coupler State) The information on the coupler state
(running with SYSTEM indicator)
0: Normal state
1: Error
• Cause 1: Error occurred in the coupler initialization
and settings, etc.
• Cause 2: Error occurred in the field network
connection, etc.
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5. Object Models

In the DeviceNet network, the method and procedures of data exchange among the nodes are
designed via multiple object groups. An object is a collection of abstract representations of a specific
component in an DeviceNet device, including their class and instances together with services and
functions.

• Terms and definitions for the object model

Term Definition

Object It is an abstract expression of the components of a product, defining its
attributes and data, services and functions, and behaviors to determine an
object.

Class It is the generalization of an object, containing the components
implemented by the instances.

Instance It consists of multiple attributes and has the same attributes, behaviors,
and services even though the instances within the class are different.

Attributes It represents the attributes of data or objects provided by the DeviceNet
device. It contains the information of the slave device and values of
input/output data.

Services It is the procedure or action performed by an object, applicable to the
classes and attributes. CIP defines common services applied to attributes.

Behaviors It defines the object functions to a specific event.
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5.1. Supported Object Classes
Object Class Code Reference

Identity 0x01 →  5.3, “Identity Class (0x01)”

Message Router 0x02 →  5.4, “Message Router Class (0x02)”

DeviceNet 0x03 →  5.5, “DeviceNet Class (0x03)”

Connection 0x05 →  5.6, “Connection Class (0x05)”

Acknowledge Handler 0x2B →  5.7, “Acknowledge Handler Class (0x2B)”

5.2. Data Types
Data Type Data Size Data Unit

USINT (Unsigned Short Integer) 8-bit 1-byte

UINT (Unsigned Integer) 16-bit 1-word

UDINT (Unsigned Double Integer) 32-bit 2-word

BOOL (Boolean) True (1) / False (0) 8-bit

STRUCT (Structure of…) - -

ARRAY (Array of…) - -
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5.3. Identity Class (0x01)
It provides the product information about Vendor ID and Device Type to identify the slave device.

5.3.1. Services

Service Code Service Name Description

0x01 Get_Attribute_All It returns the attribute value of an instance
or class.

0x0E Get_Attribute_Single It returns the value of a specific attribute.

0x05 Reset It executes the service to reset the device.
0: Restart the device
1: Restart the device to proceed with
factory reset

5.3.2. Instance Attributes

• Instance 1

Attribute ID Access Rule Name Data Type Description

1 Get Vendor ID UINT Vendor ID info.: 801 (0x321)

2 Get Device Type UINT Device type: 12 (0x0C)

3 Get Product
Code

UINT Product code assigned by the vendor
: 201 (0xC9)

4 Get Revision STRUCT F/W Revision info.: Ver 1.2
(Major = 1, Minor = 2)Get Major USINT

Get Minor USINT

5 Get Status WORD The current status of the device

6 Get Serial
Number

UDINT Serial number of the device: 0xC9

7 Get Product
Name

SHORT_
STRING

Product name: ARIO_C_DN
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5.4. Message Router Class (0x02)
It transfers the explicit messages to another object.
The services and instance attributes are not supported.
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5.5. DeviceNet Class (0x03)
It contains the information for DeviceNet network configuration such as MAC ID and baud rates, etc.

5.5.1. Services

Service Code Service Name Description

0x0E Get_Attribute_Single It returns the value of a specific attribute.

0x10 Set_Attribute_Single It modifies the value of a specific attribute.

5.5.2. Instance Attributes

• Instance 1

Attribute ID Access Rule Name Data Type Description

1 Get/Set MAC ID USINT MAC ID (node address) of the device
• Range: 00 to 63

3 Get BOI
(Bus-Off
Interrupt)

BOOL Settings of CAN communication connection
status when Bus-Off is detected
0: Maintain Bus-Off state
1: Reset the device t to establish
communication

4 Get Bus-Off
Counter

USINT The counting number of Bus-Off detection
• Range: 0 to 255

6 Get MAC ID
Switch
Changed

BOOL Switching the MAC ID of the coupler
0: MAC ID did not change
1: MAC ID changed
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5.6. Connection Class (0x05)
It consists of an object representing the connection information between two nodes in the DeviceNet
network, and the attributes of each object define the connection behavior of the device. The instance
of the Connection object determines how to process and transmit the process data.

5.6.1. Services

Service Code Service Name Description

0x0E Get_Attribute_Single It returns the value of a specific attribute.

0x10 Set_Attribute_Single It modifies the value of a specific attribute.

0x05 Reset It executes the service to reset the device.
0: Restart the device
1: Restart the device to proceed with
factory reset

5.6.2. Instances

Instance ID Connection Type Description

1 Explicit Messaging Explicit message connection

2 Poll I/O connection Data is exchanged cyclically by the request of the master.

3 Bit-Strobe I/O Connection Data is exchanged by the 1-bit output signal (a command)
of the master.

4 Change of State (COS),
Cyclic I/O connection

COS: Data is exchanged with the master when a state of
slave is changed.
Cyclic: The slave sends the data to the master every
selected cycle time.
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5.6.3. Instance Attributes

Instance 1, 2, 3, 4

Attribute ID Access Rule Name Data Type Description

1 Get Connection
State

USINT Status of the object

2 Get Connection
Type

USINT Explicit messages or I/O connection

3 Get Transport
Type

USINT Definition of the connection behaviors

4 Get Produced
Connection
ID

UINT Produced connection ID assigned to CAN
identifier field

5 Get Consumed
Connection
ID

UINT Consumed connection ID assigned to CAN
identifier field

6 Get Initial
Comm
Characteris
tics

USINT Definition of message groups for
production/consumptions data

7 Get Produced
Connection
Size

UINT Maximum size of transmit data (byte)

8 Get Consumed
Connection
Size

UINT Maximum size of received data (byte)

9 Get/Set Expected
Packet
Rate

UINT Definition of timing value related to the
Connection

10, 11 - - - Not used
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Attribute ID Access Rule Name Data Type Description

12 Get Timeout
Action

USINT Definition of the Connection object action
(How to handle Inactivity and Watchdog
timeout)

13 Get Produced
Path
Length

UINT The byte size of the Produced Connection
Path attribute

14 Get/Set Produced
Connection
Path ID

Array of
USINT

Specifies the Application objects, whose
data are generated in this connection
object

15 Get Consumed
Path
Length

UINT The byte size of the Consumed Connection
Path attribute

16 Get Consumed
Connection
Path ID

Array of
USINT

Specifies the Application objects, whose
data are received by this connection object

17 Get Inhibit Time USINT Definition of the minimum time between
data transmission
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5.7. Acknowledge Handler Class (0x2B)
Processing the response message of the slave.

5.7.1. Services

Service Code Service Name Description

0x0E Get_Attribute_Single It returns the value of a specific attribute.

0x10 Set_Attribute_Single It modifies the value of a specific attribute.

5.7.2. Instance Attributes

• Instance 1

Attribute ID Access Rule Name Data Type Description

1 Get/Set Ack.
Timer

UINT Wait time for a confirmation
• Range: 1 to 65535
• Default: 16 ms

2 Get/Set Ack.
Handler
Retry
Limit

USINT Counting number of Acknowledge
Timeouts before the application is notified
about a RetryLimit_Reached
• Range: 0 to 255
• Default: 1

3 Get COS
Produced
ID

UINT An instance that provides information
about Acknowledge Handlers (but, it
includes the I/O Application object path)
• Default: 0x04
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6. CX-Programmer Guide

• Be sure to see the version compatibility table of the ARIO Series on our Autonics
website to check the software/firmware(SW) and hardware(HW) versions of the
coupler and modules.

• Refer to the  7.2, “Update the Firmware Version” to update to the latest
software(firmware) version.

6.1. Before You Begin
Firstly, this chapter describes how to connect the ARIO unit, arranged as shown in the figure below,
to the DeviceNet master.
After that, the following descriptions are given in this chapter:
• Read the input signals on channel 1 to 4 of the digital input module (DI08N, slot 1).
• Write the output signals on channel 1 to 4 of the digital output module (DO08N, slot 3).
• Monitor the data of connected modules.

Configuration of the ARIO unit
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Configuration of the DeviceNet Master

• OMRON PLC CPU: CJ2M-CPU31

• OMRON DeviceNet Master unit: CJ1W-DRM21

• DeviceNet Baud rate: 125 kbps (DIP switch setting: 1 and 2 OFF)

• Project Planning Software

Software CX-Programmer Ver 9.5 CX-Integrator Ver 2.58

Device connection
and configuration

- PLC CPU
- DeviceNet master unit
- PC

- PLC CPU
- DeviceNet master unit
- ARIO unit
- PC

Network connections USB (PLC CPU ↔ PC) Ethernet (PLC CPU ↔ PC)

Functions Reading and writing PLC data DeviceNet network configuration
Automatic scan the I/O size
Check the I/O memory address

Settings of the ARIO coupler

• The setting of Node address (MAC-ID): 6
Set the positions of the decimal rotary switches to 06.

• The setting of baud rate: 0 (= 125 kbps)
Set the position of the DATARATE rotary switch to 0.
(Set the baud rate same as the type of the DeviceNet master.)

This chapter only describes based on the OMRON’s master (PLC) and software.
For detailed information on communication connection and usage method with the
master, refer to the user manuals provided by the specific manufacturer.
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6.2. Create a OMRON PLC Project
1. Launch the CX-Programmer.

2. Click the  (New) button on the toolbar.

3. Configure the connected PLC CPU in the Change PLC window and click the OK .

◦ Device Type: CJ2M, CPU Type: CPU31

◦ Network Type: USB

4. Press the ctrl + S  to specify the project file name of the CX-Programmer and save it to the desired
location.

5. Click the  (Work Online) button on the toolbar. Click the Yes  in the pop-up window to connect to
the PLC.
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6. Click the  (Program Mode) button on the toolbar.
Click the Yes  in the pop-up window to change the PLC operating mode to the program mode.

7. Double-click the IO Table and Unit Setup in the project workspace.

50 　 Autonics | ARIO-C-DN



8. When expanding the Main Rack in the PLC IO Table window, you can figure out that the DeviceNet
Master unit is not added.

9. Click the Options » Create in the top menu. Click the Yes  in the pop-up window to proceed with the
create IO table and initialize CPU bus settings.
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10. Click the Transfer  in the Transfer from PLC window. Click the OK  in the Transfer Results window.

11. The DeviceNet master unit is added to the Main Rack.
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6.3. Validate the Scan List
1. Double-click the added DeviceNet Master unit in the PLC IO Table window to open the parameter list

window.

2. Set the value of the Scan List Clear Switch parameter to ON and click the Transfer(PC to Unit) .
Click the Yes  in the pop-up window to transfer the parameters to the DeviceNet Master unit.
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3. Change again the value of the Scan List Clear Switch parameter to OFF.
In this time, set the value of the Scan List Enabled Switch parameter to ON and click the Transfer(PC

to Unit) . Click the Yes  in the pop-up window to transfer the parameters to the DeviceNet Master unit.
Click the OK  at the bottom of the parameter list window after the transmission is completed.

4. The green LED lights up on the SYSTEM and MNS indicators of the ARIO coupler.
The green LED lights up on the NS indicator of the CJ1W-DRM21 (the DeviceNet Master unit).
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5. Click the Options » Start Special Application » Start with Settings Inherited in the top menu
to launch the CX-Integrator.
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6.4. CX-Integrator Guide

6.4.1. Install the EDS File

Electronic Data Sheets (EDS) files contain information about the data and
communication functions of the coupler for DeviceNet connection.
You can install and manage EDS files on your project planning software.

1. Download the EDS file of ARIO-C-DN on our Autonics website.

2. Refer to the README.txt in the downloaded folder and select the EDS file suitable for the S/W version
of the coupler.

3. Click the Tools » EDS file » Install… in the top menu of CX-Integrator.

4. Select the EDS file and click the Open .
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6.4.2. Configure the Communication
1. Click the  (Communication Settings) on the toolbar.

2. Configure the connected PLC CPU in the Change PLC window and click the OK .

◦ Device Type: CJ2M, CPU Type: CPU31

3. Set the Network Type for the connected PLC CPU in the Change PLC window and click the OK .

◦ Network Type: Ethernet

◦ Network Settings: Click the Driver tab and set the IP address of the PLC.
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4. Click the  (Work Online) button on the toolbar. Click the (3) Work Online  in the pop-up window to
connect to the PLC.

5. You can see that the Target PLC and DeviceNet Master unit are connected to the Relay PLC in the
online information window.
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6.4.3. Add the ARIO Unit
1. Right-click » Connect on the added DeviceNet Master unit.

2. Click the Transfer  in the bottom of the pop-up window.

3. The network configuration is represented as shown below after the scan is completed.
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4. Double-click the DeviceNet Master unit.

5. Check the data size and memory address of the input/output data of the connected ARIO unit
on the General tab in the Edit Device Parameters window.

◦ Data size of output module (Out Size): 10-byte

◦ Start address of output data (Out Ch): 3206

◦ Data size of input module (In Size): 10-byte

◦ Start address of input data (In Ch): 3306
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6.5. Read the Input Data
1. Double-click the Memory in the project workspace of CX-Programmer.

2. Double-click the CIO in the PLC Memory window. The CIO window is created on the right side of the
screen.
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3. Click the Online » Monitor in the top menu.
Enter the 3306 of the starting address of the input data in the CIO window and press the Enter  key.
You can see that the input signals are given to channel 1 to 4 of the first digital input module.

+0 +1 +2 +3 +4

CIO3306 00 0F 00 00 00 00 00 00 00 00

Channel Ch. 1 to 8 Ch. 1 to 8 Ch. 4 Ch. 3 Ch. 2 Ch. 1

Input module DI 2 DI 1 AI 3
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6.6. Write the Output Data
1. Double-click the Memory in the project workspace of CX-Programmer.

2. Double-click the CIO in the PLC Memory window. The CIO window is created on the right side of the
screen.
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3. Enter 3206 of the starting address of the output data in the CIO window and press the Enter  key.
Enter the 0F to give output signals to channel 1 to 4 of the first digital output module and press the
Enter  key.

4. Click the Online » Transfer to PLC on the top menu. Firstly, check the Transfer Range in the pop-up
window and then click the Transfer To PLC . (The green LEDs light up on the 1 to 4 channel indicators
of the digital output module.)
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5. You can see the output channels under the Monitor mode.

+0 +1 +2 +3 +4

CIO3206 00 0F 00 00 00 00 00 00 00 00

Channel Ch. 1 to 8 Ch. 1 to 8 Ch. 4 Ch. 3 Ch. 2 Ch. 1

Output module DO 2 DO 1 AO 3
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7. DAQMaster

7.1. Monitor the ARIO Unit
1. Connect the CONFIG port of the ARIO coupler to the PC where the DAQMaster is installed.

2. Select the Supported Device List » AUTONICS » ARIO Config to add the ARIO coupler and then
select the Connect » Scan to import the connected ARIO unit. (Comm Mode state)
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3. When Selecting the I/O List » ARIO Config, the tag list of the connected input/output module is
displayed. Double-click the tag to be monitored to add it on the DAQ List window.

4. The tags are added on the DAQ List window as shown below.
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5. Double-click the RunTime Screen » Data » (e.g.) Multi Panel to configure the visualized monitoring
screen. A multi-panel window will be created on the DAQ Space window.

6. Drag and drop the tags added on the DAQ List window to the Multi Panel window.
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7. When selecting the Project » Run, you can monitor the channel status of the module.
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7.2. Update the Firmware Version
You can check the firmware (software) version of the coupler on the Comm Mode » Property tab of
the coupler » FW Version in the DAQMaster. To update the coupler’s firmware, you need to select the
Comm Mode » Property tab of the coupler » System configuration.

With Internet connection

1. Select the Firmware update  to perform the update.

Without Internet connection

1. Download the latest firmware version of the coupler from the Autonics website.

2. Select the Load firmware file  to import the downloaded .zip file.

3. Select the latest version of ARIO-C-DN at the Firmware version list .

4. Select the Firmware update  to perform the update.
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72 　 Autonics | ARIO-C-DN



8. Dimensions

• For the detailed drawings, follow the Autonics website.

• Unit: mm

Coupler

8. Dimensions 　 73



End module

98
.4

33 5
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9. Specifications

9.1. Electrical/Mechanical Specifications
Max. number of
connectable modules ≤ 32 (The length of connected modules: ≤ 384 mm)

Memory size • Input: 255-byte
• Output: 255-byte

Power supply • Unit (coupler + module): ≤ 9.6 W, ≤ 400 mA (≤ 200 mA/CH, 2-CH/COM)
• I/O: ≤ 96 W, ≤ 4,000 mA (≤ 2,000 mA/CH, 2-CH/COM)

Supply voltage • Coupler input voltage: 24 VDC

• ABUS supply voltage: 5 VDC, ≤ 960 mA
• I/O supply voltage: 24 VDC

Current consumption • The standby and run mode: 200 mA
• The maximum load: 400 mA (at coupler max. load)

Field network
connection 5-pin PCB connector

DAQMaster connection USB 2.0 type Micro B

Installation method DIN rail mounting

Material Terminal: PA6, Body: MPPO, Base: PA6, POM

Unit weight
(packaged)

≈ 165 g
(≈ 265 g)
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9.2. Environmental Conditions
Insulation resistance ≥ 100 MΩ (500 VDC megger)

Dielectric strength 1000 VAC 50/60 Hz for 1 minute

Noise immunity 500 VDC the square wave noise (pulse width: 1 ㎲) by the noise simulator

Vibration 0.7 mm double amplitude at frequency of 10 to 55 Hz (for 1 minute)
in each X, Y, Z direction for 1 hour

Vibration
(malfunction)

0.5 mm double amplitude at frequency of 10 to 55 Hz (for 1 minute)
in each X, Y, Z direction for 10 minutes

Shock 300 m/s² (≈ 30 G) in each X, Y, Z direction for 3 times

Shock (malfunction) 100 m/s² (≈ 10 G) in each X, Y, Z direction for 3 times

Ambient temperature -10 to 55 ℃, storage: -25 to 70 ℃ (no freezing or condensation)

Ambient humidity 35 to 85 %RH, storage: 35 to 85 %RH (no freezing or condensation)

Protection rating IP20 (IEC standard)

76 　 Autonics | ARIO-C-DN



10. Communication Interface

10.1. CAN Bus
Comm. standard CAN (Controller Area Network)

Cable spec. The cable approved by the Open DeviceNet Vendors Association (ODVA)

Baud rates 125 / 250 / 500 kbps (via rotary switch)

Cable length • Baud rate: 125 kbps

Trunk cable Drop cable

Thick cable: ≤ 500 m
Thin cable: ≤ 100 m

Thick/Thin cable: ≤ 6 m
Cumulative drop line: ≤ 156 m

• Baud rate: 250 kbps

Trunk cable Drop cable

Thick cable: ≤ 250 m
Thin cable: ≤ 100 m

Thick/Thin cable: ≤ 6 m
Cumulative drop line: ≤ 78 m

• Baud rate: 500 kbps

Trunk cable Drop cable

Thick cable: ≤ 100 m
Thin cable: ≤ 100 m

Thick/Thin cable: ≤ 6 m
Cumulative drop line: ≤ 39 m

Protocol DeviceNet (Type: Group 2 Only Slave)

Connection object Explicit messages, I/O messages

Communication type Poll, Bit-Strobe, Cyclic, COS (Change of State)

Number of nodes ≤ 64

Address settings Decimal rotary switches, DAQMaster

Topology Trunk, Drop Line, Daisy Chain

EDS file Download the EDS file on our Autonics website
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10.2. ABUS
Transmission rate 4 Mbps

Topology Bus, Drop Line
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