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Preface

Thank you for purchasing Autonics products.
Be sure to read and follow the Safety Precautions thoroughly before use.
This manual contains information about the product and how to use it properly, so keep it in a place
where users can easily find it.

Preface 　 5
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Manual Guide

• Use the product after fully reading the contents of the manual.

• The manual explains the product functions in detail and does not guarantee the contents other than
the manual.

• Any or all of the manual may not be edited or copied without permission.

• The manual is not provided with the product.

• Download and use from our website (www.autonics.com).

• The contents of the manual are subject to change without prior notice according to the improvement
of the product’s performance, and upgrade notices are provided through our website.

• We put a lot of effort to make the contents of the manual a little easier and more accurate.
Nevertheless, if you have any corrections or questions, please feel free to comment through our
website.

Manual Guide 　 7
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Common Symbols in the Manual

Failure to follow instructions may result in serious injury or death.

Failure to follow instructions may result in injury or product damage.

Supplementary explanation of the function

Example of that function

Important information about the feature

Common Symbols in the Manual 　 9
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Safety Considerations

Observe all 'Safety Considerations' for safe and proper operation to avoid hazards.

　Warning
1. Fail-safe device must be installed when using the unit with machinery that may cause serious injury

or substantial economic loss. (e.g., nuclear power control, medical equipment, ships, vehicles,
railways, aircraft, combustion apparatus, safety equipment, crime/disaster prevention devices, etc.)
Failure to follow this instruction may result in personal injury, fire or economic loss.

2. Do not use the unit in the place where flammable/explosive/corrosive gas, high humidity, direct
sunlight, radiant heat, vibration, impact, or salinity may be present.
Failure to follow this instruction may result in explosion or fire.

3. Do not disassemble or modify the unit.
Failure to follow this instruction may result in fire.

4. Do not connect, repair, or inspect the unit while connected to a power source.
Failure to follow this instruction may result in fire.

5. Check ‘Connections’ before wiring.
Failure to follow this instruction may result in fire.

　Caution
1. Use the unit within the rated specifications.

Failure to follow this instruction may result in fire or shortening the life cycle of the product.

2. Use dry cloth to clean the unit, and do not use water or organic solvent.
Failure to follow this instruction may result in fire or electric shock.

3. When connecting the power input and output, use AWG 22-16 cable and check the connecting
method of crimp terminal.
Failure to follow this instruction may result in fire or malfunction due to contact failure.

4. Keep metal chip, dust, and wire residue from flowing into the unit.
Failure to follow this instruction may result in fire or product damage.

5. Do not connect or disconnect connector (terminal) wire or power, when the product is operating.
Failure to follow this instruction may result in fire or malfunction of the product.

Safety Considerations 　 11



　Cautions during Use
1. Follow instructions in ‘Cautions during Use’. Otherwise, It may cause unexpected accidents.

2. BUS power and I/O power should be insulated by the individually insulated power device.

3. Power supply should be insulated and limited voltage/current or Class 2, SELV power supply device.

4. Use the rated standard cables and connectors. Do not apply excessive power when connecting or
disconnecting the connectors of the product.

5. Keep away from high voltage lines or power lines to prevent inductive noise.
In case installing power line and input signal line closely, use line filter or varistor at power line and
shielded wire at input signal line. For stable operation, use shield wire and ferrite core, when wiring
communication wire, power wire, or signal wire.

6. Do not use near the equipment which generates strong magnetic force or high frequency noise.

7. Do not touch the module communication connector part of the base.

8. Do not connect, or remove the base while connected to a power source.

9. For removing the terminal, body or base, do not operate units for a long time without it.

10. This unit may be used in the following environments.
① Indoors (in the environment condition rated in ‘Specifications’)
② Altitude max. 2,000 m
③ Pollution degree 2
④ Installation category II

The specifications and dimensions of this manual are subject to change without any notice for product
improvement. Be sure to read and follow the considerations written in the instruction manual, other
manuals, and technical information on our Autonics website.
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1. Reference Manuals

Be sure to read the reference manuals below to use the product correctly and follow
the precautions written in these manuals.
You can download the reference manuals on our Autonics website.

Installation manual It contains information for you to setup and install the ARIO Unit.

1. Key features of ARIO Series

2. Environmental conditions and handling method for
installation

3. Installation precautions

4. Instructions about maintenance, etc.

1. Reference Manuals 　 13



Coupler manual It contains information for you to configure and use the coupler
in the field network.

1. Communication protocol overview

2. Hardware information: specifications, indicators, connection
diagram, and dimensions, etc.

3. Software information: process images, and mapping
information, etc.

Module manual It contains information on the modules provided by Autonics.

1. Hardware information: specifications, indicators, connection
diagram, and dimensions, etc.

DAQMaster user manual It contains information and usage guides on ARIO-related
functions supported by DAQMaster, the comprehensive device
management program.

1. Change properties of the coupler and modules

2. Module configuration via virtual mode

3. Check the address map of the Unit

4. Check the diagnostic information of the coupler

5. Update the firmware version of the coupler, etc.

14 　 Autonics | ARIO-C-CL



2. Overview of the ARIO-C-CL

2.1. CC-Link Protocol
CC-Link, one of the Fieldbus networks, is an industrial network composed of a topology of RS-485.
It supports the transmission distance of up to 100 meters at a transmission rate of 10 Mbps as well as
up to 64 stations with a high speed and deterministic data communication. The link scan time
supported by CC-Link can process the input signals of sensors that require a high-speed response or for
intelligent devices that require a large capacity of data communication. The data link system also
supports reducing wiring and costs for building a distributed system.

The ARIO-C-CL supports the CC-Link protocol. This coupler composes the physical structure of
connected modules and devices and creates input and output process images linked with the data of
CC-Link. The process images make it possible to experience a flexible installation environment, such as
the mixed arrangement of analog and digital modules.

2.1. CC-Link Protocol 　 15



2.2. Unit Descriptions

1. CC-Link Communication Connector It is a connector to connect with CC-Link master
station such as PLC.
For detailed information on the communication
cable, refer to the  2.3, “CC-Link Communication
Connector”.

2. DATARATE Rotary Switch It is a setting switch to set the transmission rate in
the CC-Link communication network.
For detailed information on setting the
transmission rate, refer to the  2.4, “Set the
Transmission Rate”.

3. Decimal Rotary Switches It is a setting switch to designate the station
number of the coupler in the CC-Link
communication network. You can also set the
station number in the DAQMaster.
For detailed information on addressing method,
refer to the  2.5, “Assign the Station Number”.
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4. CONFIG Port It is a port to connect to the PC where DAQMaster is
installed.

1. Port type: USB Type-B Micro

5. Indicators It displays the status of the coupler and
communication connection as shown below.
For detailed information on the indicators,
refer to the  3, Indicators.

1. Power and operating status of the coupler

2. CC-Link communication status

6. Power Supply Terminal It is a terminal block that supplies power to the
coupler and peripherals.
For detailed information on the device supply,
refer to the  2.6, “Connections of the Power
Terminal”.

7. Power Supply contacts It is a contact that feeds the power input from the
power supply terminal.

1. Top input contacts: feed the power supply for
the coupler, module, and ABUS to be operated.

2. Bottom input contacts: feed the power supply
for input and output signals of the connected
module.

2.2. Unit Descriptions 　 17



2.3. CC-Link Communication Connector

• Be sure to use the connector and cable approved by the CC-Link Partner Association
(CLPA).

The 5-pin PCB connector is used for the CC-Link communication connection.
For more information on the pin assignment, refer to the table below.

Pin no. Marking on the connector Color Description

1 DA: DATA A Blue RS-485 High signal

2 DB: DATA B White RS-485 Low Signal

3 DG: Data Ground Yellow Ground for RS-485 signal

4 SH: Shield - Shield

5 FG: Frame Ground - Frame Ground
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2.4. Set the Transmission Rate

• Be sure to use the connector and cable approved by the CC-Link Partner Association
(CLPA).

• Be sure not to exceed the maximum cable length of each transmission rate.

• The maximum overall cable distances are described based on the terminal resistor
110 Ω. For more information on the relationship between the cable distance and
terminal resistor, refer to the CC-Link specifications sheet.

Refer to the table below to set the transmission rate via the DATARATE rotary switch.
Be sure to set the transmission rate of the coupler the same as that of the CC-Link master station.

Number of
occupied stations 01)

Rotary switch
setting

Transmission
rate

Maximum
overall cable
distance

Automatic assignment
depending on the data size of the module
• Occupied stations: 1 to 4 stations
• Extended cyclic setting: 1, 2, 4, 8 times

0 156 kbps ≤ 1200 m

1 625 kbps ≤ 900 m

2 2.5 Mbps ≤ 400 m

3 5 Mbps ≤ 160 m

4 10 Mbps ≤ 100 m

• Occupied stations: 4 stations fixed
• Extended cyclic setting: 1 time

5 156 kbps ≤ 1200 m

6 625 kbps ≤ 900 m

7 2.5 Mbps ≤ 400 m

8 5 Mbps ≤ 160 m

9 10 Mbps ≤ 100 m

01) Refer to the  5.2, “CC-Link Memory Map Layout”.

2.4. Set the Transmission Rate 　 19



2.5. Assign the Station Number

• It is recommended to designate the station number of the coupler the same as the
value of the rotary switches.

• The station number cannot be applied while the coupler is operating.

• Be sure to start the coupler again to apply the changed station number.

You can assign the coupler’s station number via two decimal rotary switches.
Be sure to set the station number not to be duplicated with other stations considering occupied station
numbers in each station (slave stations of the data link).

Rotary switches (x10, x1) Station number

00 The station number assigned by the DAQMaster

01 to 64 1 to 64

[Example] CC-Link system configuration
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2.5.1. Assign the Station Number in the DAQMaster
1. Set the positions of the coupler’s decimal rotary switches to 00.

2. To designate the station number in the DAQMaster, go to the Comm Mode » Property tab of the
coupler » Node Address and press the Enter key.

3. Reset the ARIO unit in the DAQMaster.

4. The station number assigned by the DAQMaster is applied.

2.5. Assign the Station Number 　 21



2.6. Connections of the Power Terminal

Terminal no. Name Description

1, 7 System Power (24 VDC) Power supply for the coupler, module and
ABUS to be operated.
• The terminals feed the power supply to the
top input contacts.
• The POWER indicator lights up.

2, 8 System Power (0 VDC)

3, 9 Not Connected (NC) -

4, 10 Field Power (Positive: 24 VDC) Power supply for the input and output (I/O)
signals of the module.
• The terminals feed the power supply to the
bottom input contacts.
• The IO POWER indicator lights up.

5, 11 Field Power (Negative: 0 VDC)

6, 12 Frame Ground / Shield Frame ground
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3. Indicators

The indicators of the ARIO-C-CL coupler consist of elements indicating the operating status for the
coupler, and connection status for the field network (CC-Link) as shown in the figure below.
For detailed information on each indicator, refer to the following tables below.

3. Indicators 　 23



3.1. LEDs for the Coupler Status
1. The power supply status of the coupler

Indicator LED color Status Description

POWER Green ON Supply voltage: Normal

OFF Supply voltage: None

2. The status of the standby mode

Indicator LED color Status Description

SYSTEM Green ON Normal operation

Flashing Standby for connecting the master after
initialization of the coupler

OFF Stop

Red ON • Coupler initialization failure (non-recoverable)
• An unrecoverable error occurred.
• The type of field network and firmware version
mismatch (non-recoverable)

Flashing • Field network initialization failure
(non-recoverable)
• Changing the settings of rotary switches
(applicable models)

OFF Normal operation

3. The status of the module communication (ABUS)

Indicator LED color Status Description

DIAG Green ON Normal operation: Multi/Single-packet works

Flashing Hot-swap (normal state)

OFF • The operation of the coupler stopped
• An error occurred

Red ON ABUS communication error

Flashing The models of the replaced module and the
previous one mismatch (normal operation)

Flashing (2 times) No module connection (non-recoverable)

Flashing (3 times) Abnormal module operation (non-recoverable)

Flashing (4 times) The number of modules and data size exceeded

OFF Normal operation
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4. The status of power supply for the module

Indicator LED color Status Description

IO POWER Green ON Supply voltage for the I/O signals of modules
: Normal

OFF Supply voltage for the I/O signals of modules
: None

3.1. LEDs for the Coupler Status 　 25



3.2. LEDs for the Field Network Status
1. The status of CC-Link communication and error

Indicator LED color Status Description

L RUN/ERR Green ON Data link is being executed.

OFF • Data link is in the standby state
• Unable to detect carrier in the data channel
• Timeout
• Hardware (PLC CPU) reset

Red ON • CRC error
• Station number error (The range of station numbers is
exceeded other than 0 to 64 including the master station)
• DATARATE rotary switch error
(transmission rate setting error)

Flashing
(0.4 sec)

The settings of transmission rate and station number are
changed while the coupler is running.

OFF • Data link is being executed.
• Hardware (PLC CPU) reset
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Refer to the timing chart below for the flashing operation of indicators.
The operation is repeated as flashing every 200 microseconds and standby
for 1 second.

3.2. LEDs for the Field Network Status 　 27



28 　 Autonics | ARIO-C-CL



4. Process Images

4.1. Memory Map
The ARIO unit composes the memory map in its memory space to assign and manage the data
collected by the coupler and modules. The master in the field network controls the input and output
devices via this memory map generated by the ARIO unit.

The memory map is created based on the arrangement and data structure of the ARIO unit as shown in
the figure below. The memory map of modules consists of each module and contains its data.
The memory map of the coupler allocates the data considering the type (input or output) and
sequence of connected modules (e.g., the slot number of each module), and data size to the read and
write areas, making it easy to calculate the location of the master’s register. In this way, the memory
map comprised by the ARIO unit creates the input and output process images for data exchange.

• READ area
It is the area that transmits the data collected by the unit to the master in the field network.
It contains the input and diagnostic data.

• WRITE area
It is the area that transmits the output commands from the master of the field network.
It contains the output data.

4.1. Memory Map 　 29



4.2. Data Processing in the Module
The data of the module is processed depending on the input and output signals.

• Digital modules
The bit-oriented digital module indicates the value of the corresponding bit position as 1.
The size of each channel is 1 bit and is grouped into bytes.

• Analog modules
The byte-oriented analog module indicates the value of the input or output signal to the
corresponding bytes. The size of each channel is grouped into words.

Module Example of input/output format Data processing size

Digital input/output
: Bit-oriented

2 channels/module (2-CH/module) 1-byte

4 channels/module (4-CH/module) 1-byte

8 channels/module (8-CH/module) 1-byte

16 channels/module (16-CH/module) 2-byte (= 1-word)

Analog input/output
: Byte-oriented

8-bit/channel (8-bit/CH) 1-byte

12-bit/channel (12-bit/CH) 2-byte (= 1-word)

16-bit/CH (16-bit/CH) 2-byte (= 1-word)

24-bit/channel (24-bit/CH) 4-byte (= 2-word)
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4.2.1. Check the Data of the Modules
You can check the data of modules connected with the coupler as shown in the figure below.
To check the data, go to Comm Mode » Run » I/O Monitor in the DAQMaster.
The binary, decimal, and hexadecimal are supported as the display format in the DAQMaster.

1. The value of input signals on the point (or channels) 1 and 2 of the digital input module
• Binary 0000 0011 (0x03)

2. The value of a voltage of 10.000 V applied to channel 1 of the analog input module
• Big endian: 0x270D (≈ 10,000DEC)

The data arrangements (the order or sequence) of the analog signal can be
expressed as big-endian or little-endian in the DAQMaster.
To select the endianness, go to Comm Mode » Property tab of the coupler »
Endian. (factory setting: Big-endian)
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4.3. Example of the Process Image
You can check the input and output process images of the unit (coupler + modules) on the AddressMap

menu in the DAQMaster. Firstly, the input modules are mapped, and then the output modules are
mapped. The first position of the input process image contains diagnostic information of the coupler
with a size of 16 bits (1 word).

The process image of the CC-Link protocol is composed of information in 16 bits units through the
Remote registers (RWr and RWw). The coupler does not use the information in bit units such as Remote
input and output (RX and RY) for the data exchange.

DAQMaster: An arrangement example of the ARIO unit

DAQMaster: The address map of the ARIO unit
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4.3.1. Input Process Image

Byte Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 0: Coupler Diagnostic Data High Byte 01)

1 Diagnostic data Low Byte 01)

2 2: DI04P - Ch.4 Ch.3 Ch.2 Ch.1

3 3: AI02V1 Ch.1 High Byte

4 Ch.1 Low Byte

5 Ch.2 High Byte

6 Ch.2 Low Byte

7 5: AI02V1 Ch.1 High Byte

8 Ch.1 Low Byte

9 Ch.2 High Byte

10 Ch.2 Low Byte

11 7: DI04P - Ch.4 Ch.3 Ch.2 Ch.1

12 9: DI04P - Ch.4 Ch.3 Ch.2 Ch.1

01) Refer to the  4.3.3, “Mapping of the Coupler Diagnostic Data”.

4.3.2. Output Process Image

Byte Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 1: AO02V1 Ch.1 High Byte

1 Ch.1 Low Byte

2 Ch.2 High Byte

3 Ch.2 Low Byte

4 4: DO04P - Ch.4 Ch.3 Ch.2 Ch.1

5 6: DO04P - Ch.4 Ch.3 Ch.2 Ch.1

6 8: DO08P Ch.8 Ch.7 Ch.6 Ch.5 Ch.4 Ch.3 Ch.2 Ch.1
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4.3.3. Mapping of the Coupler Diagnostic Data
To check the value of the coupler diagnosis in the DAQMaster,
go to Comm Mode » Property tab of the coupler » Coupler State.

Byte Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 High Reserved

1 Low CS MS WP AEM - ACS AT AC

AC (ABUS Configuration) The diagnostic information for the configuration of the
coupler and modules
0: Normal state
1: Module configuration error
• Cause 1: No connected modules
• Cause 2: The number of connected modules exceeded
• Cause 3: The data size of module exceeded
• Cause 4: Invalid arrangement of modules

AT (ABUS Timeout) The occurrence information of timeout
0: Multi-packet state (normal)
1: Single-packet state (timeout occurred)
• Cause 1: The module detached
• Cause 2: The module not recognized due to a noise
• Cause 3: Hot-swap state
• Cause 4: The module operation error

ACS (ABUS Communication State) ABUS communication status
0: Normal state
1: Communication error
• Cause 1: Replaced module mismatched
• Cause 2: Unknown communication error occurred

AEM (ABUS Empty Module) Checking the connected module
0: Normal state (one or more modules connected)
1: No module connected

WP (Warranty Period) Notice of product warranty period
(≤ 3 years, 157,680DEC)
0: Within the warranty period
1: End of warranty period
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MS (Module State) The status of connected modules
(running with DIAG indicator)
0: Normal state
1: Error

CS (Coupler State) The information on the coupler state
(running with SYSTEM indicator)
0: Normal state
1: Error
• Cause 1: Error occurred in the coupler initialization
and settings, etc.
• Cause 2: Error occurred in the field network
connection, etc.
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5. CC-Link Address Area

5.1. Data Types
The remote device station exchanges bit unit or word unit data through the cyclic transmission.
The data types handled by CC-Link are shown in the table below.

Data unit Signal name Description

Bit RX
(Remote input)

The input data transmitted from the remote station
to the master station

RY
(Remote output)

The output data transmitted from the master
station to the remote station

Word RWr
(Remote register read/receive)

The input data transmitted from the remote station
to the master station

RWw
(Remote Register write/transmit)

The output data transmitted from the master
station to the remote station

5.2. CC-Link Memory Map Layout
• CC-Link operating mode: Ver 2.0

• Number of occupied stations per unit: 1 to 4 stations

• Extended cyclic setting: 1, 2, 4, 8 times

Occupied
stations Signal 1 cycle 2 cycles 4 cycles 8 cycles

1 station
RX, RY 32-bit each 32-bit each 64-bit each 128-bit each

RWr, RWw 4-word each 8-word each 16-word each 32-word each

2 stations
RX, RY 64-bit each 96-bit each 192-bit each 384-bit each

RWr, RWw 8-word each 16-word each 32-word each 64-word each

3 stations
RX, RY 96-bit each 160-bit each 320-bit each 640-bit each

RWr, RWw 12-word each 24-word each 48-word each 96-word each

4 stations
RX, RY 128-bit each 224-bit each 448-bit each 896-bit each

RWr, RWw 16-word each 32-word each 64-word each 128-word each
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5.3. Memory Map of the ARIO Unit
1. Data area of the remote I/O

• The ARIO coupler does not use the RX and RY for the data exchange.

Link input Signal name Link output Signal name

RX00 to RX3F Reserved RY00 to RY3F Reserved

2. Data area of the remote register

• The "n" is the start I/O number assigned to the master station.

• Example of CC-Link configuration: 2 occupied stations, 1 cycle (1 time)

• Total data size of RWr/RWw: 8-word each

Link register Signal name Link register Signal name

RWrn0 Coupler Diag. RWwn0 AO 1, channel 1

RWrn1 DI 1, channel 1 to 4
AI 1, channel 1 MSB

RWwn1 AO 1, channel 2

RWrn2 AI 1, channel 1 LSB
AI 1, channel 2 MSB

RWwn2 DO 1, channel 1 to 4
DO 2, channel 1 to 4

RWrn3 AI 1, channel 2 LSB
AI 2, channel 1 MSB

RWwn3 DO 3, channel 1 to 4

RWrn4 AI 2, channel 1 LSB
AI 2, channel 2 MSB

RWwn4 Not used

RWrn5 AI 2, channel 2 LSB
DI 2, channel 1 to 4

RWwn5 Not used

RWrn6 DI 3, channel 1 to 4 RWwn6 Not used

RWrn7 Not used RWwn7 Not used
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6. GX-Works2 Guide

• Be sure to see the version compatibility table of the ARIO Series on our Autonics
website to check the software/firmware(SW) and hardware(HW) versions of the
coupler and modules.

• Refer to the  7.2, “Update the Firmware Version” to update to the latest
software(firmware) version.

6.1. Before You Begin
Firstly, this chapter describes how to connect the ARIO unit, arranged as shown in the figure below,
to the CC-Link master station.
After that, the following descriptions are given in this chapter:
• Read the input signals on channel 1 to 4 of the digital input module (DI08N, slot 1).
• Write the output signals on channel 1 to 4 of the digital output module (DO08N, slot 3).
• Monitor the data of connected modules.

Configuration of the ARIO unit
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Configuration of CC-Link master station

• Mitsubishi PLC CPU: Q03UDV

• Mitsubishi Network Module: QJ61BT11N

• Project Planning Software: GX-Works2 Ver 1

Settings of the ARIO coupler

• The setting of station number: 1
Set the positions of the decimal rotary switches to 01.

• The setting of transmission rate: 10 Mbps
Set the value of the DATARATE rotary switch to 9.
(Set the transmission rate same as the type of PLC CPU.)

• Endian: Little endian
The PLC used in this chapter supports the little-endian format.
To select the Little endian in the DAQMaster, go to communication mode » Properties tab of
coupler » Endian.

This chapter only describes based on the Mitsubishi’s master (PLC) and software.
For detailed information on communication connection and usage method with the
master, refer to the user manuals provided by the specific manufacturer.
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6.2. Create a Mitsubishi PLC Project
1. Click the Project » New… in the top menu.

2. Configure the properties of connected PLC in the New Project window and click the OK .

• Series: PLC CPU series name

• Type: PLC CPU model name

• Language: Ladder
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3. Double-click the Project View » Parameter » PLC Parameter on the left side of the screen.

4. To register the MAIN program, click the Insert  on the Program tab in the Q Parameter Setting
window.
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5. To import the information on the currently connected PLC, click the Read PLC Data  on the I/O
Assignment tab in the Q Parameter Setting window. (The PLC and ARIO unit are in the Online state.)

6. To check an error occurrence, click the Check  at the bottom of the Q Parameter Setting window.

7. To save the settings, click the End .
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6.3. Configure the CC-Link Parameters

6.3.1. General Settings
1. Double-click the Project View » Network Parameter » CC-Link on the left side of the screen.

44 　 Autonics | ARIO-C-CL



2. To set each parameter in the CC-Link Module Configuration window, refer to the descriptions below.

◦ Number of Modules: The number of modules connected to the PLC CPU

◦ Start I/O No.: The head address of the network module

◦ Type: Master Station (→ CC-Link Master Board)

◦ Mode: Remote Net (Ver.2 Mode) (→ CC-Link Ver 2.0)

◦ Total Module Connected: The number of couplers connected to the CC-Link network

◦ Remote register(RWr, RWw): Start address of ARIO input/output module (e.g., D100, D200)

◦ Station Information Setting: Configuration of the coupler connected to the CC-Link network
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3. To configure the coupler, click the Station Information .

4. The CC-Link Station Information Module window appears.
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5. To configure the coupler, refer to the descriptions below.

Station Type

Select the Ver.2 Remote Device Station (only CC-Link Ver 2.0 is supported.)

Number of Occupied Stations and Expanded Cyclic Setting

◦ Set the occupied station and extended cyclic setting the same as the DATARATE rotary
switch setting of the coupler.

◦ The figure above shows:

▪ Occupied stations: 4 stations,

▪ Extended cyclic setting: Single (1 time),

▪ because the value of the DATARATE rotary switch of the coupler is 9.

Number of
occupied stations 01)

Rotary switch
setting

Transmission
rates 02)

Automatic assignment
depending on the data size of the
module
• Occupied stations: 1 to 4 stations
• Extended cyclic setting: 1, 2, 4, 8 times

0 156 kbps

1 625 kbps

2 2.5 Mbps

3 5 Mbps

4 10 Mbps

• Occupied stations: 4 stations fixed
• Extended cyclic setting: 1 time

5 156 kbps

6 625 kbps

7 2.5 Mbps

8 5 Mbps

9 10 Mbps

01) Refer to the  5.2, “CC-Link Memory Map Layout”.
02) It must be the same as the transmission rate of the master.
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6. If multiple devices are connected and the number of occupied stations is different, designate the
number right side of the Station No. as the station number. Set the positions of decimal rotary
switches on the coupler to that station number.

7. To check an error occurrence, click the Check  at the bottom of the CC-Link Station Information
Module window. To save the settings, click the End .

48 　 Autonics | ARIO-C-CL



8. To check an error occurrence, click the Check  at the bottom of the CC-Link Module Configuration
window. To save the settings, click the End .
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6.3.2. Settings with CSP+

1. Install the CSP+ File

CC-Link Family System Profile Plus (CSP+) file defines the information of connected
devices in CC-Link and CC-Link IE Field system. The CC-Link project planning software
uses the CSP+ files to enable data exchange between the master and coupler. This file
contains information about device specifications, parameters related to the network
(occupied station and station type), input/output data (memory map), etc.

1. Download the CSP+ file of the ARIO-C-CL on our Autonics website.

2. Refer to the README.txt in the downloaded folder and select the CSP+ file suitable for the S/W
version of the coupler.

3. Launch the GX-Works2.

4. Click the Tool » Profile Management » Register… in the top menu before opening a project file.
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5. Select the downloaded CSP+ file and click the Register .

6. To install the CSP+ file, click the OK .
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2. Configure the CC-Link parameters

1. Double-click the Project View » Network Parameter » CC-Link on the left side of the screen.

2. Firstly, select the checkbox of Set the station information in the CC-Link configuration window in
the CC-Link Module Configuration window. To set each parameter, refer to the descriptions below.

◦ Number of Modules: The number of modules connected to the PLC CPU

◦ Start I/O No.: The head address of the network module

◦ Type: Master Station (→ CC-Link Master Board)

◦ Mode: Remote Net (Ver.2 Mode) (→ CC-Link Ver 2.0)

◦ Total Module Connected: Automatic setting after the CC-Link configuration

◦ Remote register (RWr, RWw): Enter the start address of ARIO input/output module after the
CC-Link configuration.

◦ Station Information Setting: Configure the coupler via CSP+ file.
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3. To configure the coupler, click the CC-Link Configuration Setting .

4. The CC-Link Configuration Module window appears.
Check whether Module List » CC-Link Module (Autonics Corporation) » ARIO-C-CL is added on the
right side of the screen.

5. Drag and Drop the ARIO-C-CL to the Host Station direction.
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6. Set the # of STA Occupied the same as the value of the DATARATE rotary switch on the coupler.

◦ Mode Setting: Ver.2 Mode (→ CC-Link Ver 2.0) / TX Speed: Transmission rate

Number of
occupied stations 01)

Rotary switch
setting

Transmission
rates 02)

Automatic assignment
depending on the data size of the module
• Occupied stations: 1 to 4 stations
• Extended cyclic setting: 1, 2, 4, 8 times

0 156 kbps

1 625 kbps

2 2.5 Mbps

3 5 Mbps

4 10 Mbps

• Occupied stations: 4 stations fixed
• Extended cyclic setting: 1 time

5 156 kbps

6 625 kbps

7 2.5 Mbps

8 5 Mbps

9 10 Mbps

01) Refer to the  5.2, “CC-Link Memory Map Layout”.
02) It must be the same as the transmission rate of the master.

7. If multiple devices are connected and the number of occupied stations is different, designate the
number right side of the Station No. as the station number. Set the positions of decimal rotary
switches on the coupler to that station number.

54 　 Autonics | ARIO-C-CL



8. Click the Close with Reflecting the Setting  in the top menu.

9. The number of couplers connected to the Total Module Connected is applied.
Specify the start address of the ARIO input/output module to the Remote Register (RWr, RWw).

10. To check an error occurrence, click the Check  at the bottom of the window after the configuration is
completed. To save the settings, click the End .
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11. Click the View » Docking Window » Device Reference in the top menu.

12. To check the mapping information of the ARIO unit, select the Start I/O No. in the Device
Reference(CC-Link) window.
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6.4. Download the Program
1. Click the Online » Write to PLC… in the top menu.

2. Click the Parameter+Program  in the Online Data Operation window.
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3. Click the Execute  after confirming that all checkboxes of the Target below are selected.

4. Download is completed. Reset the PLC CPU.
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6.5. Monitor the I/O Data
1. Click the Online » Monitor » Device/Buffer Memory Batch in the top menu.

2. Enter the D100 which is the start address of RWr to the Device Name.
You can see that the input signals are applied to channel 1 to 4 of the first digital input module.
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3. To check the address of the output module, enter the D200 which is the start address of RWw to the
Device Name. To apply the output signals to channel 1 to 4 of the first output module, double-click
the value area on the right side of the mapping of the bits.

4. Enter the value of 15 to the Value area and click the Set . (15dec = Binary 0000 1111)
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5. You can see that the output signals are applied as shown in the figure below.
(The channel indicators (no. 1 to 4) of digital output module light up.)

6.5. Monitor the I/O Data 　 61
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7. DAQMaster

7.1. Monitor the ARIO Unit
1. Connect the CONFIG port of the ARIO coupler to the PC where the DAQMaster is installed.

2. Select the Supported Device List » AUTONICS » ARIO Config to add the ARIO coupler and then
select the Connect » Scan to import the connected ARIO unit. (Comm Mode state)
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3. When Selecting the I/O List » ARIO Config, the tag list of the connected input/output module is
displayed. Double-click the tag to be monitored to add it on the DAQ List window.

4. The tags are added on the DAQ List window as shown below.
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5. Double-click the RunTime Screen » Data » (e.g.) Multi Panel to configure the visualized monitoring
screen. A multi-panel window will be created on the DAQ Space window.

6. Drag and drop the tags added on the DAQ List window to the Multi Panel window.
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7. When selecting the Project » Run, you can monitor the channel status of the module.
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7.2. Update the Firmware Version
You can check the firmware (software) version of the coupler on the Comm Mode » Property tab of
the coupler » FW Version in the DAQMaster. To update the coupler’s firmware, you need to select the
Comm Mode » Property tab of the coupler » System configuration.

With Internet connection

1. Select the Firmware update  to perform the update.

Without Internet connection

1. Download the latest firmware version of the coupler from the Autonics website.

2. Select the Load firmware file  to import the downloaded .zip file.

3. Select the latest version of ARIO-C-CL at the Firmware version list .

4. Select the Firmware update  to perform the update.

7.2. Update the Firmware Version 　 67
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8. Dimensions

• For the detailed drawings, follow the Autonics website.

• Unit: mm

Coupler

8. Dimensions 　 69



End module

98
.4

33 5
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9. Specifications

9.1. Electrical/Mechanical Specifications
Max. number of
connectable modules ≤ 32 (The length of connected modules: ≤ 384 mm)

Memory size • Input: 256-byte
• Output: 256-byte

Power supply • Unit (coupler + module): ≤ 9.6 W, ≤ 400 mA (≤ 200 mA/CH, 2-CH/COM)
• I/O: ≤ 96 W, ≤ 4,000 mA (≤ 2,000 mA/CH, 2-CH/COM)

Supply voltage • Coupler input voltage: 24 VDC

• ABUS supply voltage: 5 VDC, ≤ 960 mA
• I/O supply voltage: 24 VDC

Current consumption • The standby and run mode: 200 mA
• The maximum load: 400 mA (at coupler max. load)

Field network
connection 5-pin PCB connector

DAQMaster connection USB 2.0 type Micro B

Installation method DIN rail mounting

Material Terminal: PA6, Body: MPPO, Base: PA6, POM

Unit weight
(packaged)

≈ 165 g
(≈ 265 g)
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9.2. Environmental Conditions
Insulation resistance ≥ 100 MΩ (500 VDC megger)

Dielectric strength 1000 VAC 50/60 Hz for 1 minute

Noise immunity 500 VDC the square wave noise (pulse width: 1 ㎲) by the noise simulator

Vibration 0.7 mm double amplitude at frequency of 10 to 55 Hz (for 1 minute)
in each X, Y, Z direction for 1 hour

Vibration
(malfunction)

0.5 mm double amplitude at frequency of 10 to 55 Hz (for 1 minute)
in each X, Y, Z direction for 10 minutes

Shock 300 m/s² (≈ 30 G) in each X, Y, Z direction for 3 times

Shock (malfunction) 100 m/s² (≈ 10 G) in each X, Y, Z direction for 3 times

Ambient temperature -10 to 55 ℃, storage: -25 to 70 ℃ (no freezing or condensation)

Ambient humidity 35 to 85 %RH, storage: 35 to 85 %RH (no freezing or condensation)

Protection rating IP20 (IEC standard)
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10. Communication Specifications

10.1. CC-Link Communication
Comm. standard CC-Link Ver 2.0

Station type Remote device station (max. number of connected stations: ≤ 42 stations)

Transmission rate
setting DATARATE rotary switch X 1

Transmission rates 156 kbps / 625 kbps / 2.5 Mbps / 5 Mbps / 10 Mbps

Cable spec. The cable approved by the CC-Link Partner Association (CLPA)

Cable length • 156 kbps: 1200 m
• 625 kbps: 900 m
• 2.5 Mbps: 400 m
• 5 Mbps: 160 m
• 10 Mbps: 100 m

Station number
settings Decimal rotary switches X 2

Station number 01 to 64

Occupied station 1 to 4 stations

Extended cyclic
setting 1, 2, 4, 8 times

Interface type RS-485

Topology Bus, Trunk, Drop Line, Daisy Chain

CSP+ file Download the CSP+ file on our Autonics website

10.2. ABUS
Transmission rate 4 Mbps

Topology Bus, Drop Line
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